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Question: What were computers invented to
do? OK! OK! They were invented to calcu-
late the trajectories of cannon balls, but
what did everybody except the military
want them for? Databases! And, what do
most computer users never do? Make data-
bases! So, let’s make a database.

A database is a list of stuff. It might be a list
of addresses, recipes, a store’s inventory, a
catalog, insurance records, a library card
catalog, your checking account (Quicken is
just a non-customizable database) or any-
thing else. What makes a computer data-
base useful is that items can be sorted
quickly and easily. An example might be a
recipe database with perhaps 1000 recipes.
With such a database, you could instantly
pull out all recipes that contained both eggs
and cheese without manually sorting out
Yorkshire pudding and chocolate cake. In
fact, you could sort such a database by any
attribute like title, ingredients, cooking
time or who in the family likes it. So, let’s
make a recipe database.

Our old friend AppleWorks does databases as
one of its many abilities and, since most of
us have AppleWorks (or its pre-cursor, Cla-
risWorks), let’s use AppleWorks to make our
recipe database.

First, a bit of thought. Before we open Apple-
Works, we need to plan. What categories of
information do we want to have? It’s best
to make a list, here’s mine:

1) Category (appetizer, entree, dessert, etc.)
2) Title
3) Ingredients

4) Directions (method of preparation)
5) Notes

Launch AppleWorks. When Starting Points ap-
pears, click the Database icon. The Define

Database Fields window opens. You need to
name each field. Call the first one Catego-
ries and, from the Field Type list, choose:
Pop-up Menu and click once on the Create
button. The Options for Pop-up Menu Field
window appears, type the first category:
Soup in the Item Label field and click Create.
Soup is added to the list above. Repeat for
Appetizer, Entree, Salad and Dessert (add
some more categories if you like). When all
have been added to the list, click the OK
button. Notice that Categories is now in the
list of Field Names.

Now, we need a Title field. Type Title in as
Field Name and change the Field Type to
Text. Click the Create button. Repeat this

for the Ingredients, Directions and Notes
fields. When all of the fields are listed un-

der Field Name, click the Done button.

It begins to look like a database. You can now
see the fields and their labels. However,
much is yet to be done.
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you to manually search through your records
(each recipe is called a record in database-
talk). Find is for searching for a specific word
or phrase. Use Layout to design the look of
your database. List shows your records in a
compact list. Below the views you see a check
mark next to Show Multiple, click this to re-
move the check mark. By doing so, you will



only see one recipe record at a time rather than several on each
page. I find this easier to read. If you prefer to see multiple reci-
pes simultaneously, recheck Show Multiple.

Choose Layout from the Layout menu. Suddenly, you see the size
and shape of the fields that will contain your information. Now,
you can get creative with the database’s look and organization.

Here is how the raw layout of your database looks.

We need more working room, so click on the little box marked
Body and drag it down to the bottom of the window.

Next, move the fields around by clicking on them and dragging
them to new positions. You can change field sizes by clicking on
the little boxes, that appear on the borders of selected fields, and
dragging them (as is shown at right for the Title field). Move the
bold-face field labels into position, if you like.

You can further customize the layout by adding colors to the
fields and the lines that define their edges. Use the drawing and
color tools in the Tool Palette to make these changes.

Double-click on a field to show the field’s Text Style attributes.
Change font, size and color to fit your whims.

To change the font, size, etc. for the labels, click on one, high-
light the words (just as you do with other text) and choose your
font preferences from the Format menu.

As you make your changes, use the Layout menu to switch fre-
quently from Layout mode to Browse mode. In Browse mode, you
see how the database will look when you use or print it. Change
back to Layout mode to make changes and adjustments to the
look of the database. Below right is the final look of my recipe
database. (By the way, my mother-in-law’s Green Chili Omelet
is fabulous!)
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At last, we get to add the recipes. The in- EI
formation that is added to a database || = L4
is, of course, data. Gather your data: 3
by 5 recipe cards, magazine clippings,
cookbooks and add your data likeso: [

Green Chili
Omelet

1) From the Edit menu, choose New [
Record. I
2) A blank form appears. Click once
on the empty Title field, a flashing in-
sertion point appears. Type in the title
of the first recipe.

3) Click once on the Ingredients field
and type in the ingredients. Do the
same for Directions and Notes.

4) Click and hold on the Categories
field and choose from the pop-up list.

Notes

Laverne Venus

Ingredients

Cledda chesse, giated

Morteey Jack cheese, grated

2-4oz. cars clopped Oetega peppers

6 Eggs
2.5C milk

(< I3

Category |eggsicheese W

Fiench bread to cover bottom of 8¥13 pan
Butter

Paprilea

Cregaro

Directions

Butter bresrl anyl amenige butter side up to cover bottom of pen. S prinkle giated cheese over
Tread to cover and 1o taste. Sprinkle chopped chilies over chesse. Best 6 eggs, ad2.5C
milk; best. Pow egg/milk mixture over chesse and clilies. Dust with papriloaand
aregano. Refiigeste S5+ howrs. Bake 325° for S0mimtes.

OX0 pen: wse 4 eggs, 1C milk.
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Getting around. Keep adding recipes until you have at least
20 (any less and you may as well just keep using the old 3 by
5 cards). If you are feeling really ambitious, add a couple of
thousand (you really could!). Now that you have so many
recipes, you can put the database to work for you.

In order to find things in the database, you need to know
how to navigate around it. AppleWorks makes this easy by
imitating a Rolodex filing system. The graphic at right shows
how this works. Just click to flip the cards forward and back
to page through the records. Notice the little tab that sticks
out of the right side of the “Rolodex”. Click on and slide this
tab up and down to speed through your records. As you
move the tab, you'll see that if you move it half way down
and stop, you will be approximately at the mid-point in
your records. Move the tab one quarter of the way and you
will be at the 25% point, and so on.

Get it in order. Let’s put the database in alphabetical order by
title. Here’s how:

1) Choose Sort Records... from the Organize menu.

2) The Sort Records window opens.

3) Click on Title in the Field List to highlight it.

4) Click the Move button and Title moves to Sort Order.
5) Click the Ascending order button to alphabetize A to Z
(click Descending order to alphabetize Z to A).

6) Click the OK button to complete.

Find it. The easy way to find a record is to use the database’s
Find layout. Do this:

1) From the Layout menu, choose Find. This puts the data-
base into the Find layout. Note that the fields are now emp-
ty of data and ready for input.

2) Click in the field that you want to search. Click in the 7i-
tle field to search by title. Click in the Ingredients field to
search for recipes that use a specific ingredient, etc.

3) Type in what you want to search for.

4) Click the Find button (or tap your Return or Enter key).

AppleWorks will search through all of your records and se-
lect only the ones that contain the words that you request-
ed. I searched on Beans and found six bean recipes. Apple-
Works shows this where it lists Records: 6 (178). This note
means that there are six bean recipes out of 178 total reci-
pes. If I click the “Roladex,” I will be able to page through
the six bean recipes without having to sort through the 172
non-bean recipes. This makes finding records quick and
easy. It also allows for a bit of serendipity. If I had searched
on Boston Baked Beans I would have found only that. By
searching on Beans I see five other recipes as well.

AppleWorks Database Navigation Tools
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Get back to it. Once you are done
searching, choose Show All Records
from the Organize menu and all 178
records become visible again.

Multiple searches. You can search on
more than one criterion at a time. Just
enter search terms in more than one
field and AppleWorks will only show
you records that match your request.
This can be very handy with address
lists. You may want to send out holi-
day cards first to folks in New Jersey.
To do so, you could search your ad-
dresses for only folks who are on the
card list AND live in New Jersey. The
Match Records... command under the
Organize menu, allows very complex
and specific searches. AppleWorks
Help (found under the Help menu) can
aid you in learning how these work.

Label it. Speaking of address databas-
es, one of the most needed functions
is printing sticky-back address labels.
AppleWorks has built-in, most of the
Avery line of labels (don’t buy any oth-
er brand as damage to your printer
may result). Here’s how to use them:

1) Create your address database and
enter your data.

2) From the Layout menu, choose New
Layout.
3) Give the new layout a name (I like to

California Computer Care
P.0. Box 9445
Santa Rosa, CA 95405

(800) 540-8989

help@calcompcare.com

Like an
auto club
for your
computer,

name label layouts after the Avery num-
ber that I'm using).

4) Click the Labels button.

5) Click and hold on the Custom but-
ton and choose your particular Avery
label from the list.

6) Click the OK button.

7) The Set Field Order window appears.
8) In the Field List box, click on a field
that you want to appear on the labels.
9) Repeat for all fields that you want
to appear on the address labels.

10) Click the OK button.

11) The new layout appears (to switch
back to your original layout, go to the
bottom of the Layout menu and choose
the layout without a check mark).

12) Choose Layout from the Layout
menu. Drag the fields around to the
order you like and the appearance you
want. Choose font and size now, too,
just like when you originally created
the database.

13) Once you have the appearance set,
choose Browse from the Layout menu.
14) The labels will NOT appear on
screen as they will print on the Avery
label sheet, so a test print is in order.
Sacrifice a label sheet to the database
gods and print a sample page. Odds
are that the data will not perfectly align
with the diecut labels on the sheet. If
you need to adjust the alignment up,
down or left and right, use the Docu-

ment command from the Format menu
to adjust the margins. Do another test
print to see if things align properly
now. Once alignment is set, you need
not worry about it again. Now, you
can print as many labels as you like.

Databases are fun and useful. Give them
a try. You'll soon have lists of every-
thing in the house!
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ComputerWare is gone again. Ma-
rin Co. has once more lost its best
authorized Mac retailer and repair
center. Elite Computers, who
bought the ComputerWare name
from the previous owners, has de-
cided to quit business entirely cit-
ing problems with their relation-
ship with Apple. Once again, many
good people have lost their jobs and
a good resource for Mac products,
repair and advice is no more.

Options for Marin Co. are thin, but
many Apple resellers and warranty

repair centers can be found in San
Francisco and Santa Rosa. To find

an authorized sales and service cen-
ter, go to:

http://buy.apple.com
and click on the appropriate link.




